如何自動更新WordPress版本

前言

最近WordPress版本也到了5.0了,也是時候該更新WordPress版本了,在本文章中,會簡易的展示該如何在WordPress上自動更新版本。

前置環境

  • 一台裝有WordPress主機
  • 有基本WordPress技巧

設定wp-config.php檔案

wp-config.php檔案中含有WordPress相關的設定,為了讓WordPress直接自動更新,需要加入以下的設定到此檔案中。

在更新WordPress動作之前,需要先將wp-config.php和wp-config-sample.php都放置到web document root目錄下


define('FS_METHOD','direct');

接著就可以自動更新了,而且不會詢問需要設定FTP帳密了。

安全性問題

在自動更新完成之後,需要將上述兩個設定檔案移除,其原因是因為避免有心人士透過其他方式去竄改此檔案,造成網站的crash。

通常就我的做法,我自動更新完成之後,就會把上述的兩個設定檔移到現在的目錄上一層,並把權限調整為只有讀取的權限,也就是400。可以透過下列的指令達成:


sudo chmod 400 wp-config.php wp-config-sample.php

參考資料

在WordPress 5.0底下如何切換到傳統編輯器

前言

最近把WordPress從4.9版本升級到5.0了,但是文章的編輯器換成最新一代,叫做「Gutenberg 」的編輯器,看起來很像medium.com編輯模式,不過現階段還是比較想用傳統的編輯模式,本文章教學,就是展示在WordPress 5.0底下換成傳統編輯器方式。

預先環境

  • 已經有WordPress 5.0以上的網站
  • 有一般的WordPress知識

安裝傳統編輯器外掛

因為在WordPress 5.0的時候,傳統編輯器就轉為外掛的形式,內建是新的編輯器,所以需要先將名為「Classic editor plugin」外掛安裝起來。外掛網址

設定編輯器

安裝好傳統編輯器之後,接著到WordPress後台,點選旁邊的設定→寫作,在寫作頁面可以看到如下圖的地方可以選擇要使用的編輯器。

改成傳統編輯器之後按下「儲存變更按鈕」,再回到文章編輯的地方,就會轉成以前的傳統編輯器頁面了。

參考資料